Intermittent Service Degradation
Incident Report for MODX Cloud
Resolved
Service restored. Multiple causes of excessive resource usage were identified and mitigated, including poorly written code resulting in IO spikes, PHP scripts improperly handling large file delivery, and MySQL queries creating excessive connections and running too long. Protections have been put in place to prevent future recurrence, and additional monitoring is being put into place to help identify abnormal resource usage in the future.
Posted 12 days ago. Sep 12, 2017 - 15:03 CDT
Monitoring
We are closely monitoring AMS and TX data centers due to intermittent service degradation. In addition we are in the process of provisioning additional hardware to increase capacity in both of these locations. If you need help, please either open a ticket from the MODX Cloud Dashboard or email support [at] modxcloud.com.
Posted 12 days ago. Sep 12, 2017 - 11:23 CDT