Free SSL Service Disruption
Incident Report for MODX Cloud
Resolved
Let‘s Encrypt service has been restored.
Posted 4 months ago. May 19, 2017 - 08:43 CDT
Identified
Our Free SSL provider, Let‘s Encrypt, is experiencing a service disruption. This means that free SSL certificates cannot currently be issued from the MODX Cloud dashboard, and some certificates that are in the process of being renewed may show an error status. Since we start the renewal process 30 days before certificate expiry, there is a wide margin of time for completing the renewals. Please contact support if you have any specific concerns or questions.
Posted 4 months ago. May 19, 2017 - 08:27 CDT