All Services Unavailable
Resolved
Mar 18, 2026 at 7:10pm UTC
Service Incident Report - March 9, 2026
Summary
On March 9, 2026, MODX Cloud experienced an outage affecting all customer platforms between 9:26 AM and 1:27 PM Central Time (approximately 4 hours). This incident was caused by our infrastructure provider incorrectly changing the network configuration, blocking public Internet access to our servers. Service was restored without data loss beginning at 10:18 AM. We are working with our vendor on additional proactive measures and processes to prevent similar future issues.
What Happened
Our infrastructure provider introduced a new automated self-serve platform in February. An error in this platform failed to record cleared payments. Despite our account being in good standing, this triggered an automated suspension of network access which incorrectly flagged our account as past due.
This automated suspension occurred despite our account having explicit instructions requiring contact with both our account representative and our operations team prior to any service changes not initiated by our operations team. No account status notifications were sent via email or phone to us or to our account representative. We have confirmed this issue affected multiple customers.
When the outage began, our team immediately contacted our infrastructure provider's account representative, who confirmed he was unaware of any account problems, and opened a Severity 1 ticket with support. After escalation, the provider confirmed they had received our payment but failed to process it correctly.
Timeline (Central Time)
9:26 AM - Outage detected, all platforms offline
9:39 AM - Infrastructure provider's account manager contacted
10:09 AM - Provider confirmed payment located, began restoration
10:18 AM - Public Platforms restored (~52 minutes)
11:44 AM - Private Server restoration began (~2.5 hours after detection)
1:27 PM - All services confirmed operational (~4 hours)
1:39 PM - Final platform recovery completed
Impact
- All MODX Cloud customers and sites were affected
- Sites were unavailable for 1-4 hours depending on platform type
- No data loss or corruption occurred
- Recovery required extensive manual intervention by our team
What We Did
Our team responded immediately:
- Contacted our infrastructure provider within 13 minutes of detection
- Escalated through multiple channels when initial response was inadequate
- Manually restored application services as infrastructure came back online
- Verified all platforms were operational before declaring resolution
Root Cause
This outage was entirely outside our control and resulted from our infrastructure provider's internal payment processing failure. We had paid our account in full and on time. The provider has acknowledged this was their error.
What We're Doing to Prevent This
We are taking the following actions:
Immediate:
- Demanded a formal incident review from our infrastructure provider (ongoing)
- Required a revision of their escalation procedures for mission-critical accounts
Short-term:
- Implement additional account monitoring and notification systems independent of the vendor's tooling
- Establish redundant communication channels and methods with our provider
- Evaluating multi-provider redundancy options to reduce single-point-of-failure risk
Long-term:
- Comprehensive infrastructure diversification assessment
- Evaluate failover capabilities across multiple providers
Our Commitment
This incident has shown us that even paid, current accounts with major publicly traded infrastructure providers are vulnerable to administrative errors beyond our control. While we cannot prevent our providers from making mistakes, we are committed to:
- Reducing recovery time through better processes and redundancy
- Improving our ability to detect and respond to provider-side issues
- Ensuring this type of extended outage cannot happen again
We take full accountability for the impact this had on your operations, regardless of the cause. Your trust in MODX Cloud is our highest priority.
Questions or Concerns
If you have questions about this incident or how it affected your specific services, please contact our support team or reach out to me directly.
We appreciate your patience and understanding during this incident.
Thanks,
The MODX Cloud Team
Affected services
Updated
Mar 9, 2026 at 6:27pm UTC
All services are now back online.
What Happened?
A configuration change made in error by our infrastructure provider disabled network access for all platforms.
Our platforms and systems were unaffected. Once we identified the issue, we contacted our provider to rectify the situation.
Next Steps
We're working with our provider to determine the events and actions that led to this outage.
If you have questions or there are any issues with your individual sites, please do not hesitate to contact us at support@modxcloud.com.
Affected services
Updated
Mar 9, 2026 at 4:54pm UTC
We're still making some adjustments to bring some of the customer Private Servers back online.
Affected services
Updated
Mar 9, 2026 at 4:41pm UTC
Customer Private Servers are coming back online. The networking issue has been resolved and all sites and servers should be available normally over the next few minutes.
Please let us know if your sites are not online properly via support@modxcloud.com
Affected services
Updated
Mar 9, 2026 at 4:13pm UTC
We continue to work with our infrastructure partner to resolve the issue and bring all Private Server platforms back online.
The servers are online however network has been affected.
Affected services
Updated
Mar 9, 2026 at 3:41pm UTC
We're still working with our infrastructure partner to bring our Private Server platforms back online at this time.
Affected services
Updated
Mar 9, 2026 at 3:20pm UTC
Our infrastructure provider is resolving the issue now. Services are coming back online at this time. We will continue to monitor to ensure all systems come back online normally.
Affected services
Updated
Mar 9, 2026 at 3:11pm UTC
Our infrastructure partner is working on a resoution at this moment. Hopefully, services will start coming back online soon.
Affected services
Updated
Mar 9, 2026 at 2:57pm UTC
The issue appears to be with our infrastructure partner. We're working with them right now to restore services ASAP>
Affected services
Created
Mar 9, 2026 at 2:41pm UTC
All services at MODX Cloud are currently inavailable. We're investigating the issues and will have an update shortly.
Affected services