Back to overview
Downtime

AMS3 Platform Downtime

May 7, 2026 at 7:20am UTC
Affected services
Amsterdam 3 Platform (NL)

Resolved
May 13, 2026 at 6:29pm UTC

As of 17:46 UTC today, the AMS3 platform is back online. We are currently running standard checks and database procedures following the power restoration. Sites that have not been migrated, should begin coming back online shortly.

If you have a migration currently in progress, please do not attempt to cancel it at this time. Our support team will help guide you through your options once we have completed our checks. Please open a support ticket if you need assistance.

We will post a further update shortly.

Updated
May 12, 2026 at 3:10pm UTC

Our infrastructure provider has confirmed that the AMS3 facility is expected to come back online on Thursday, May 15. When it does, all sites that have not been migrated should come back online automatically in their pre-outage state. It may be necessary to clear your site cache after restoration—we will provide more details on this when the time comes.

Please note that all timelines are estimates and restoration may be delayed.

Sites that have already been migrated to a new datacentre will not be affected by the restoration.

If you would prefer not to wait, the Change Data Center (Recovery Mode) tool remains available in the MODX Cloud Dashboard. To begin:

  1. Open the Cloud Edit view for the affected site and click the Change Data Center (Recovery Mode) link on the right side, or click the Move to New Data Center button below the site name in the Clouds list
  2. Select a new datacentre location—your site will be restored from the most recent available backup
  3. Once the migration is complete, update your DNS record to point to the new platform's IP address
  4. Confirm the DNS change in the dashboard—this step is required for your SSL certificate to be reinstalled

If you are experiencing any issues with your migrated site, please open a support ticket.

Updated
May 11, 2026 at 2:37pm UTC

Our infrastructure provider has confirmed that recovery efforts at the AMS3 facility are progressing as expected. All three server rooms are intact with no visible smoke or water damage. Work is underway to restore access to two of the three server rooms, while equipment from the third is being migrated to an alternate room.

As of yesterday afternoon, our infrastructure provider estimated that restoration of connectivity to AMS3 was 48–72 hours away, putting the current estimate at approximately 24–48 hours from now. Please note that all timelines are estimates and restoration may take longer. When the datacenter comes back online, sites that have not been migrated should come back online automatically. It may be necessary to clear your site cache after restoration—we will provide more details on this shortly.

Sites that have already been migrated to a new datacentre will not be affected by the restoration.

If you would prefer not to wait, the Change Data Center (Recovery Mode) tool remains available in the MODX Cloud Dashboard. To begin:

  1. Open the Cloud Edit view for the affected site and click the Change Data Center (Recovery Mode) link on the right side, or click the Move to New Data Center button below the site name in the Clouds list
  2. Select a new datacentre location—your site will be restored from the most recent available backup
  3. Once the migration is complete, update your DNS record to point to the new platform's IP address
  4. Confirm the DNS change in the dashboard—this step is required for your SSL certificate to be reinstalled

If you are experiencing any issues with your migrated site, please open a support ticket.

Updated
May 8, 2026 at 3:13pm UTC

Our infrastructure provider has completed an initial assessment of the AMS3 facility. There is no visible smoke or water damage to the servers, however power loss remains the primary issue and full restoration is expected to take several days. They are working around the clock on recovery actions and will provide updates as progress is made.

We have also resolved an issue affecting some migrated sites where the PHP version was not correctly carried over, causing errors after migration. If your site is still experiencing issues, please open a support ticket.

Many customers have already successfully migrated their sites to new datacentres, and many more are currently in progress. We strongly encourage all remaining affected customers to migrate their sites using the Change Data Center (Recovery Mode) tool in the MODX Cloud Dashboard. To begin:

  1. Open the Cloud Edit view for the affected site and click the Change Data Center (Recovery Mode) link on the right side, or click the Move to New Data Center button below the site name in the Clouds list
  2. Select a new datacentre location—your site will be restored from the most recent available backup
  3. Once the migration is complete, update your DNS record to point to the new platform's IP address
  4. Confirm the DNS change in the dashboard—this step is required for your SSL certificate to be reinstalled

Updated
May 7, 2026 at 10:35pm UTC

Our infrastructure provider expects to be granted access to the affected facility at approximately 05:00 UTC on May 8, 2026, at which point they will begin their own assessment of the impact. The fire has been confirmed to be under control. There is currently no ETA for restoration of the AMS3 platform.

We still encourage you to review the instructions we send to affected customers for self migrating sites to a new platform.

Updated
May 7, 2026 at 10:24pm UTC

Our infrastructure provider has confirmed that the AMS3 outage is the result of a fire at the datacenter facility. The building has been safely evacuated with no reported injuries. The fire is believed to be contained, however the facility is assessing damage to the underlying power infrastructure and there is currently no ETA for restoration.

A self-serve site migration tool is now available in the MODX Cloud Dashboard. We ask that you prioritise migrating your live production sites first. Affected customers will receive an email shortly with detailed instructions. To begin:

  1. Open the Cloud Edit view for the affected site
  2. On the right side, click the Recovery Mode link
  3. Select a new datacentre location—your site will be restored from the most recent available backup

Once the migration is complete, update your DNS record to point to the new platform's IP address. You will be prompted in the dashboard to confirm once you've done so—this step is required for your SSL certificate to be reinstalled.

Updated
May 7, 2026 at 4:27pm UTC

At this time, our team is continuing preparations to restore sites to alternate datacentre locations.

If you are able to, we ask that you hold off on any independent recovery attempts and wait for our guided restoration process. This will provide the most streamlined path to getting your sites back online and will be based on the most recent available backup.

Stay tuned or subscribe for further updates.

Updated
May 7, 2026 at 2:44pm UTC

Our team is continuing preparations, per our disaster recovery plan, to restore sites to alternate datacentre locations.

If you are able to, we ask that you hold off on any independent recovery attempts and wait for our guided restoration process. This will provide the most streamlined path to getting your sites back online and will be based on the most recent available backup.

We will post another update shortly with more details.

Updated
May 7, 2026 at 1:21pm UTC

Our infrastructure provider has confirmed that the AMS3 datacenter outage is the result of a fire at the facility. The building has been safely evacuated with no reported injuries, and emergency services are on site. There is currently no ETA for restoration of service.

We are in the process of activating our disaster recovery process, which involves restoring sites to alternate datacentres. Further details will follow as we have them.

Updated
May 7, 2026 at 10:51am UTC

Our infrastructure provider has confirmed the AMS3 datacenter is fully offline and is actively investigating the cause. All network traffic in and out of the datacenter remains unroutable. We will continue to post updates as information becomes available.

Updated
May 7, 2026 at 9:31am UTC

We are still awaiting further information from our infrastructure provider. We'll have another update in the next 15-45 minutes.

Updated
May 7, 2026 at 9:00am UTC

We are still awaiting further information from our infrastructure provider. We'll have another update in the next 15-45 minutes.

Updated
May 7, 2026 at 8:43am UTC

We are still awaiting further information from our infrastructure provider. We'll have another update in the next 15-45 minutes.

Updated
May 7, 2026 at 8:18am UTC

We're currently waiting for guidance from our infrastructure provider, but it appears at this time that all network traffic and and out of the datacenter (AMS3) is currently not routable. We'll post more information in the next 15-45 minutes.

Created
May 7, 2026 at 7:20am UTC

We are aware of the AMS3 platform experiencing downtime. We are actively investigating and will update as soon as we have more information.