Connectivity Issues For Some Users
Resolved
Jul 13, 2026 at 10:44pm UTC
We've received the following update from our infrastructure provider, and are now monitoring the fix.
As of 19:30 UTC 13 July 2026, Network Specialists received multiple reports of customers experiencing intermittent network access to the services. Network Specialists investigated and identified a routing issue on the backbone network affecting multiple regions. Network Specialists have mitigated the route issue by 21:47 UTC 13 July 2026.
Affected services
Created
Jul 13, 2026 at 8:35pm UTC
We have been alerted that some customer sites are not reachable from certain locations around the world. We're investigating and have engaged our upstream provider for assistance. It appears to be network connectivity or routing.
Affected services