Back to overview
Degraded

GoDaddy DNS/Nameserver Outage

Dec 12, 2025 at 9:32pm UTC
Affected services
Third Party Services

Resolved
Dec 12, 2025 at 9:33pm UTC

It appears that GoDaddy has resolved the issue at this time.

Created
Dec 12, 2025 at 9:32pm UTC

It appears that customers who uses GoDaddy Nameservers may experience site unavailability until it's resolved.