Back to overview
Degraded

Cloud Dashboard issues

Jan 29 at 03:14am CST
Affected services
MODX Cloud Dashboard
CloudEdge™ CDN/WAF
Backstage™
Queued Tasks Runner

Resolved
Jan 29 at 10:25am CST

Root Cause Analysis - Service Disruption Thursday, Jan 29, 2026

Impact:

Certain MODX Cloud Dashboard functions, Backstage functions, CloudEdge, and some queued operations were unavailable for approximately 4 hours.

What happened:

The outage was caused by a DNS configuration issue that prevented an internal TLS certificate from renewing automatically. This caused several services to stop functioning properly.

Resolution and preventative measures:

We've corrected the DNS configuration and taken additional steps to prevent similar incidents:

  • Implemented enhanced monitoring to detect certificate renewal issues before they impact service
  • Updated our internal procedures to prevent similar configuration errors from happening again and to catch potential problems earlier

We apologize for the disruption and appreciate your patience while we resolved this issue.

Updated
Jan 29 at 08:24am CST

Services should be coming back online if they are not already back online. Please let us know if you continue to have issues.

Updated
Jan 29 at 08:04am CST

We have identified the issue and are actively working to resolve. This issue will affect Cloud Dashboard, CloudEdge, Updates inside Cloud Dashboard and several other services.

Created
Jan 29 at 03:14am CST

We have had reports and are aware of issues with the Cloud Dashboard that is affecting new Cloud creations and possible other Dashboard actions. We will aim to have this resolved as soon as possible.