Let's Encrypt Suspends Issuance
Resolved
May 8, 2026 at 9:17pm UTC
Let's Enrypt has resumed issuance of certificates after a brief suspension due to issues.
From LE: "Due to an issue with the cross-signed certificate from our Generation X root to our new Generation Y root, all issuance has been switched back to our Generation X root certificate. This affects our "tlsserver" and "shortlived" ACME certificate profiles."
We'll monitor for any change in this status.
Affected services
Created
May 8, 2026 at 8:01pm UTC
SSL certificate provider, Let's Encrypt has suspended certificate issuance and therefore new SSL certificates while investigating an issue.
This means MODX Cloud customers will not be able to add or renew certificates until this has resolved. Automatic renewals have a retry process and will continue to retry until renewed.
We'll continue to monitor the status for updates.
Affected services